Bug report #1934

Unable to remove shapefile field in Attribute table

Added by luca76 - about 11 years ago. Updated about 7 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:up-/downstream
Crashes QGIS or corrupts data:No Copied to github as #:11994

Description

I compiled latest SVN trunk on Ubuntu amd64.

Steps to reproduce:

1) open vector layer
2) open layer properties
3) go to attribute table
4) enable edit mode
5) try to select and delete a field. Not possible.

History

#1 Updated by Alexander Bruy about 11 years ago

Confirmed on Windows XP Pro SP3: I can create a new field but can't delete any existing field - Delete button is disabled

#2 Updated by Alexander Bruy about 11 years ago

Seems that this problem is OGR-related. OGR can't delete fields

#3 Updated by Jürgen Fischer about 11 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

QGIS queries the provider, if I can delete attributes. Depending on it's response the buttons are enabled or disabled. For the shape case OGR cannot delete attributes and therefore the button is disabled. Once support is added to OGR, QGIS will use it. So I'm closing this ticket.

See also GDAL ticket #2671

#4 Updated by Daniel Vaz about 7 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.4.0 to Version 2.0.0
  • Assignee deleted (nobody -)
  • Status changed from Closed to Reopened

GDAL ticket was concluded. I suggest to reopen and fix that bug.

#5 Updated by Jürgen Fischer about 7 years ago

  • Status changed from Reopened to Resolved
  • Resolution changed from wontfix to up-/downstream
  • Pull Request or Patch supplied set to No

Daniel Vaz wrote:

GDAL ticket was concluded. I suggest to reopen and fix that bug.

There's no bug - QGIS supports removal of shape attributes since GDAL did.

#6 Updated by Jürgen Fischer about 7 years ago

  • Status changed from Resolved to Closed
  • Target version deleted (Version 2.0.0)

#7 Updated by Daniel Vaz about 7 years ago

Sorry, I am using QGis version 1.8 on Ubuntu 12.04 and after I recompile under gdal 1.9 the option works fine. Thanks in advance

Also available in: Atom PDF