Bug report #19323

Qgis 3.0/3.2 crash when editing point geopackage layer.

Added by Patrick Dunford over 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Canvas
Affected QGIS version:3.0.3 Regression?:No
Operating System:Debian 9 Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:27151

Description

When editing point layer and moving point using the Node tool the software crashes.

Sample data coming.

bug19323.bz2 (32 KB) Patrick Dunford, 2018-07-03 04:51 PM

19323.tar.bz2 (22.8 KB) Patrick Dunford, 2018-07-21 06:43 AM

History

#1 Updated by Patrick Dunford over 2 years ago

Open the sample project
There is only one layer "osFeatures"
put this layer in edit mode and select node tool
try dragging the big blue circle you can see to somewhere

The move feature tool doesn't cause a crash

#2 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

The attached project is corrupt and missing the data - can you re-attach?

#3 Updated by Patrick Dunford over 2 years ago

#4 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Feedback to Open
  • Priority changed from Normal to High

#5 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#6 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Also available in: Atom PDF