Bug report #19243

Zooming out crashes QGIS

Added by Marten Middeldorp about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:3.0.3 Regression?:No
Operating System:Windows 10 (64-bit) Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:27071

Description

User Feedback

Simple zooming in- and out in the first QGIS tutorial (natural earth) causes QGIS to crash. Memory not an issue.

Report Details

Crash ID: 6c0c691157b8e559aa4b3c35ba55d37f0cffaf57

Stack Trace

geos::index::strtree::STRtree::STRIntersectsOp::~STRIntersectsOp :
QgsGeometryFactory::linestringFromPolyline :
QgsGeometryFactory::linestringFromPolyline :
QgsGeometryFactory::linestringFromPolyline :
QgsGeometry::makeValid :
QgsPalLabeling::prepareGeometry :
QgsPalLayerSettings::registerFeature :
QgsVectorLayerLabelProvider::registerFeature :
QgsVectorLayerLabelProvider::registerFeature :
QgsVectorLayerLabelProvider::registerFeature :
QgsMapRendererParallelJob::renderLayerStatic :
QgsMapRendererParallelJob::renderingFinished :
QgsArchive::zip :
QgsImageOperation::flipImage :
QtConcurrent::ThreadEngineBase::run :
QThreadPoolPrivate::reset :
QThread::start :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.3-Girona
QGIS code revision: 8a899c8758
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

History

#1 Updated by Nyall Dawson about 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #14752

#2 Updated by Marten Middeldorp about 2 years ago

Is there an easy fix for this issue? Trying to work through the first QGIS tutorial. This is very discouraging!

Also available in: Atom PDF