Bug report #19205

SAGA -> Terrain Analysis - Profiles -> Cross profiles gets a float where an integer is required

Added by Loren Amelang over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/SAGA
Affected QGIS version:3.0.3 Regression?:Yes
Operating System:Windows 10 Creators with 3000x2000 screen and 175% scaling Easy fix?:Yes
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27034

Description

This is like #18870. But a different SAGA module.

In QGIS 3.0.3:
Processing -> Toolbox -> SAGA -> Terrain Analysis - Profiles -> Cross profiles

'50.0' is not a correct numeric value for option 'NUM_PROFILE'.

Tried the default:
'10.0' is not a correct numeric value for option 'NUM_PROFILE'.

Looks like NUM_PROFILE is different from the other parameters:
Usage: saga_cmd ta_profiles 3 [-DEM <str>] [-LINES <str>] [-PROFILES <str>] [-DIST_LINE <double>] [-DIST_PROFILE <double>] [-NUM_PROFILE <num>]

-NUM_PROFILE:<num> Profile Samples
Integer
Minimum: 3
Default: 10

I tried to delete the decimal point and zeros from the SAGA dialog, but it puts them right back as soon as I leave the field!


Related issues

Related to QGIS Application - Bug report #18870: SAGA ... Channel Network and Drainage Basins fails due t... Closed 2018-04-27

History

#1 Updated by Nyall Dawson over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in master

#2 Updated by Jürgen Fischer over 1 year ago

  • Related to Bug report #18870: SAGA ... Channel Network and Drainage Basins fails due to Threshold being passed as a Real when Integer is required added

#3 Updated by Jürgen Fischer over 1 year ago

  • Description updated (diff)

Also available in: Atom PDF