Bug report #19080

Nautical Miles Scale Bar

Added by Geoffrey Kneller over 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.0.3 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:26910

Description

On a Mercator projection layout (EPSG:3785), adding a scale bar showing Nautical Miles as the unit of measure generates a scale bar showing 1 NM = 1' of Longitude - incorrectly. The correct answer is: 1 NM = 1' of Latitude. This worked correctly in 2.18 and seems to be broken in all the versions of 3.0 that I've tried.

bugreport.png - Image of layout showing scalebar (350 KB) Geoffrey Kneller, 2018-06-01 01:06 AM

History

#1 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

I don't believe that that definition of nautical miles is correct - from Wikipedia:

"A nautical mile is a unit of measurement defined as exactly 1,852 metres (6,076.1 ft; 1.1508 mi)."

...snip...

"In 1929, the international nautical mile was defined by the First International Extraordinary Hydrographic Conference in Monaco as precisely 1,852 metres.[1]

Imperial units and United States customary units used a definition of the nautical mile based on the Clarke (1866) Spheroid. The United States nautical mile was defined as 6,080.20 feet (1,853.24 m) based in the Mendenhall Order foot of 1893. It was abandoned in favour of the international nautical mile in 1954.[11]"

So there's no distinction here between latitude/longitude measures. QGIS layout scale bars have always used longitude as to calculate scale, so I can't see the issue here.

#2 Updated by Giovanni Manghi about 2 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF