Bug report #19079

Processing toolbox allows >10 character column names to be entered; doesn't warn user & doesn't create output

Added by Simon Dedman about 2 years ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GUI
Affected QGIS version:3.0.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26909

Description

Processing toolbox > grass > v.vect.stats joins points to polygons with a function e.g. average. It allows the user to name the output columns for count of points in each polygon, and the function result. It doesn't warn the user about the 10 character column name limit (e.g. AveragePoints is illegal) and doesn't save the output with a different name and doesn't return any warning, simply fails silently. The user has to deduce that the problem is the column name length.

Proposal:
1. Edit the form name/tips from "Column name ... exists)" to "... exists; max length 10 characters) for both count & statistics fields
2. Code in a warning or grey out the Run button if Column name length > 10, OR
3. Pop up a warning box saying "[Colname] not created as column name too long (>10 characters)".

Ideally 1 plus whichever of 2 & 3 is easier to code I guess.
Cheers

History

#1 Updated by Alexander Bruy about 1 year ago

  • Resolution set to fixed/implemented
  • Operating System deleted (Win10)
  • Status changed from Open to Closed

With GeopPackage used as default output format this is not an issue anymore

Also available in: Atom PDF