Bug report #19078

Crash when symbol width = 0 (in composer's legend)

Added by Antoine Lafranchis almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Legend
Affected QGIS version:3.0.3 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:26908

Description

User Feedback

In the composer, setting 0 in the legend property "symbol width" results in crash (either if the zero is set by direct input or with the down arrow button).

The symbol width and height properties have no effect at all for point layers.

It would be great to have the ability to use completely different symbols in the composer's legend than in the layer styles (so that the size, orientation, color can be adjusted individually). Setting symbol size to zero was a try to hide the automatic symbols so that I could replace them with different svgs.

Report Details

Crash ID: c2f21c17a04aa1719c616bf9c9a4c44e22b435f0

Stack Trace

geos::index::strtree::STRtree::STRIntersectsOp::~STRIntersectsOp :
QgsGeos::offsetCurve :
QgsGeometry::offsetCurve :
QgsSymbolLayerUtils::needSvgMarker :
QgsSimpleLineSymbolLayer::renderPolyline :
QgsLineSymbolLayer::drawPreviewIcon :
QgsSymbol::drawPreviewIcon :
QgsSymbolLegendNode::drawSymbol :
QgsLayerTreeModelLegendNode::draw :
QgsLegendRenderer::drawSymbolItem :
QgsLegendRenderer::drawAtom :
QgsLegendRenderer::paintAndDetermineSize :
QgsLegendRenderer::drawLegend :
QgsLayoutItemLegend::draw :
QgsLayoutItem::paint :
QgsLayoutItemLegend::paint :
QGraphicsScene::~QGraphicsScene :
QGraphicsScene::drawForeground :
QGraphicsScene::dragMoveEvent :
QGraphicsItem::dragMoveEvent :
QGraphicsEffectSource::draw :
QgsLayoutEffect::draw :
QGraphicsScene::drawItems :
QGraphicsScene::drawItems :
QGraphicsView::paintEvent :
QgsLayoutView::paintEvent :
QWidget::event :
QFrame::event :
QGraphicsView::viewportEvent :
QCoreApplicationPrivate::sendThroughObjectEventFilters :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QWidgetPrivate::drawWidget :
QWidgetPrivate::paintSiblingsRecursive :
QWidgetPrivate::drawWidget :
QWidgetPrivate::paintSiblingsRecursive :
QWidgetPrivate::drawWidget :
QWidgetPrivate::paintSiblingsRecursive :
QWidgetPrivate::drawWidget :
QWidgetPrivate::paintSiblingsRecursive :
QWidgetPrivate::drawWidget :
QApplication::windowIcon :
QWidget::event :
QMainWindow::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QCoreApplicationPrivate::sendPostedEvents :
QGraphicsScene::~QGraphicsScene :
QObject::event :
QGraphicsScene::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QCoreApplicationPrivate::sendPostedEvents :
qt_plugin_query_metadata :
QEventDispatcherWin32::processEvents :
CallWindowProcW :
DispatchMessageW :
QEventDispatcherWin32::processEvents :
qt_plugin_query_metadata :
QEventLoop::exec :
QCoreApplication::exec :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.3-Girona
QGIS code revision: 8a899c8758
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.15063

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #14752

Also available in: Atom PDF