Bug report #19076

GRASS r.relief.scaling has reversed Min/Max limits on 2 input arguments

Added by Garth Fletcher almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GRASS
Affected QGIS version:3.0.3 Regression?:No
Operating System:Mac OS X 10.12.6 Easy fix?:Yes
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26906

Description

GRASS: r.relief.scaling - Creates shaded relief from an elevation layer (DEM).

QGIS3's processing dialog for r.relief.scaling has reversed Min / Max limits for 2 arguments:
min max field
90 0 Altitude of sun in degrees above the horizon
360 0 Azimuth of the sun in degrees to the east of north

Thus it is impossible to enter any value other than the incorrect Min, and attempts to Run always result in an incorrect value message because the forced min value is, of course, larger than the specified max value.

Associated revisions

Revision 1c684456
Added by Nyall Dawson almost 2 years ago

[processing] Log an error when a numeric parameter has min value >= max value

Refs #19076

Revision ae95adba
Added by Nyall Dawson almost 2 years ago

[processing][GRASS] Fix r.relief.scaling has inverted min/max values for altitude and azimuth parameters

Fixes #19076

History

#1 Updated by Nyall Dawson almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#2 Updated by Garth Fletcher almost 2 years ago

Thanks!

Also available in: Atom PDF