Bug report #19074

Pandas and NetCDF4 cannot be installed for QGIS version 2.18.20

Added by Md. Muktadir Rahman over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Md. Muktadir Rahman
Category:QGIS Server
Affected QGIS version:2.18.20 Regression?:No
Operating System:Windows 10, 64-bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:26904

Description

Hello,

I am facing following error while trying to install NetCDF4 and pandas in QGIS using OSGeo4W shell:

"Could not find a version that satisfies the requirement NetCDF4 (from versions: ) No matching distribution found for NetCDF4"

"Could not find a version that satisfies the requirement panda (from versions: ) No matching distribution found for panda"

I have used the command line "pip install NetCDF4" and "pip install pandas" in the OSGeo4W shell. I have also tried importing the packages from the Python console in QGIS. (e.g. using command 'import NetCDF4' and 'import pandas'). As suggested in the manual to downgrade the netCDF4 package for the latest QGIS versions, I have run the command "pip uninstall netCDF4" following the manual using OSGeo4W shell which shows that NetCDF4 is not installed in my system showing error:

"Cannot uninstall requirement NetCDF4, not installed"

Then I have tried using the command "pip install netCDF4==1.2.9" which is again showing the following error:

"Could not find a version that satisfies the requirement netCDF4==1.2.9 (from versions: ) No matching distribution found for netCDF4==1.2.9"

I am using python27 packages and UMEP plugins 1.4.

History

#1 Updated by Alessandro Pasotti over 2 years ago

  • Resolution changed from wontfix to invalid
  • Status changed from Open to Closed

It does not look like a bug in QGIS application.

Also available in: Atom PDF