Bug report #19054

Crash when attribute table open and layer removed

Added by matteo ghetta about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Matthias Kuhn
Category:Attribute table
Affected QGIS version:3.1(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:26884

Description

If the attribute table for a vector layer is opened (as dock panel) and in the meanwhile the user remove the vector layer linked to that attribute table, QGIS crashes

Associated revisions

Revision fcb6a74d
Added by Matthias Kuhn about 2 years ago

Fix crash when removing layer with attribute table open

Fix #19054

History

#1 Updated by Alessandro Pasotti about 2 years ago

  • Assignee set to Alessandro Pasotti

#2 Updated by Alessandro Pasotti about 2 years ago

  • Regression? changed from No to Yes

It actually also crashes when the attr table is not docked (but it's a dialog)

#3 Updated by Alessandro Pasotti about 2 years ago

Probably broken since commit 53324bf13c93d15d5e8d708a3bd0d8e3ab21c6f0

#5 Updated by Matthias Kuhn about 2 years ago

  • Assignee changed from Alessandro Pasotti to Matthias Kuhn

#6 Updated by Matthias Kuhn about 2 years ago

  • Pull Request or Patch supplied changed from No to Yes

#7 Updated by Matthias Kuhn about 2 years ago

  • Status changed from Open to In Progress

#8 Updated by Anonymous about 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

#9 Updated by matteo ghetta almost 2 years ago

Works perfectly! Thanks guys

Also available in: Atom PDF