Bug report #1904

GRASS plugin crashes QGIS trying to open location from folder with cyrillics

Added by Maxim Dubinin over 11 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Lorenzo Masini
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11964

Description

subj
example folder name:
C:\\temp\\куку\\PERMANENT

Associated revisions

Revision f228d685
Added by Giuseppe Sucameli almost 10 years ago

fix #1904

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision a1887c3f
Added by Giuseppe Sucameli almost 10 years ago

fix #1904

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Giovanni Manghi over 11 years ago

confirmed also under linux

#2 Updated by Paolo Cavallini about 11 years ago

Please chack again after 43408110 (SVN r11561), which might fix it

#4 Updated by Maxim Dubinin about 11 years ago

sorry, it is a mess with those [BR]s, still don't understand why simple <enter> doesn't work as a new line in trac

#5 Updated by Maxim Dubinin about 11 years ago

ah, and btw I'm using 11659

#6 Updated by Jürgen Fischer almost 11 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

fixed in 53e47794 (SVN r12626).

#7 Updated by Maxim Dubinin almost 11 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

This is still not working in , note the change in pic2
http://gis-lab.info/images/screenshots/20091231-23r-8kb.jpg

#8 Updated by Jürgen Fischer almost 11 years ago

Replying to [comment:7 gislab]:

This is still not working in , note the change in pic2
http://gis-lab.info/images/screenshots/20091231-23r-8kb.jpg

Works on Linux for me now, but GRASS itself doesn't seem to work with cyrillic characters on Windows either. So this might be a general GRASS issue.

#9 Updated by Redmine Admin over 10 years ago

GRASS 6.4.0 wxpython seems to work with non ascii chars in gisbase name but qgis does not.

I have tried to enable toLocal8Bit instead of toUtf8 on win in r:13158.

To be checked with next build.

#10 Updated by Maxim Dubinin over 10 years ago

I'm afraid that didn't help (bcef7bbd (SVN r13188)).

After selection the location and clicking OK I've got an error:

http://gis-lab.info/images/screenshots/20100329-388-11kb.jpg

#12 Updated by Giuseppe Sucameli almost 10 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

fixed in a1887c3f (SVN r15224)

Also available in: Atom PDF