Bug report #19021

[Layout] Exporting an atlas does not bring back the map item to its initial extent at the end of the process

Added by Harrissou Santanna over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.1(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:26852

Description

In a print layout, add a map item and connect it to an atlas (zoom to the feature option).
Launch the atlas
At the end of the process, instead of putting the map in its initial state (namely, extent) as it was the case in 2.x, the map now shows the extent of the last iterated feature.

History

#1 Updated by Nyall Dawson over 2 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

This was by design in 3.x.

2.x design originally tried to isolate atlas settings from the composer, so that a single composition could be used both with atlas enabled and disabled. But that was done before atlas became so strongly tied into compositions.

Accordingly, I decided that that use case no longer was required, and that a print layout made for an atlas would only ever be used as an atlas. So in 3.x there's no longer a separation between a layout in "atlas" mode and "normal" mode, and accordingly there's no longer a concept of "initial extent" to return to!

Also available in: Atom PDF