Feature request #18911

Incomplet GUI dialogue box for GDAL processing tools (like Build Virtual Raster)

Added by Nicolas Cadieux over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GDAL
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:26743

Description

In QGis 3, it is no longer possible to modify the GDAL/OGR console call or to see the list and order of files being used as this list is generated on the fly in a temp file (buildvrtInputFiles.txt). The order of the files is very important in the module. This is because we now exclusively rely the Guild virtual Raster from the Processing tools.

The big problem is that the GUI is very incomplet as only 3 parameters are available (Resolution, layer stack, Allow projection difference) out of some 20 parameters available (like the no data value for each file) in gdalbuildvrt. (http://www.gdal.org/gdalbuildvrt.html).

We need to be able to modify the GDAL/OGR console call (with the yellow pen Icon and the help button available in previous versions of Qgis). This was not only practical but was a good learning tool as one could see and modify the console call. It also permits new GDAL algorithms to be used and that have not yet made it to the GUI. Other GDAL processing tools have the same problem.

History

#1 Updated by Nyall Dawson over 2 years ago

#2 Updated by Nyall Dawson over 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #11323

Also available in: Atom PDF