Bug report #18885

Processing native Clip algorithm does not copy the attribute table

Added by matteo ghetta over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Processing/QGIS
Affected QGIS version:3.1(master) Regression?:Yes
Operating System:any Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26717

Description

Even if the tool work fine (even with different CRS) the attribute of the original layer is not copied to the final one. SAGA tool works nice so the problem should not be in the data iteself.

In attach the input layer (point) and the mask layer (polygon) both in the same CRS.

clip.gpkg (2.23 MB) matteo ghetta, 2018-04-30 12:30 PM

Associated revisions

Revision 9809f939
Added by Nyall Dawson over 2 years ago

[memory] Fix provider cannot handle fields with complex characters in name

Fixes #18885

Revision 1b263163
Added by Nyall Dawson over 2 years ago

[memory] Fix provider cannot handle fields with complex characters in name

Fixes #18885

(cherry-picked from 9809f9394b)

History

#1 Updated by matteo ghetta over 2 years ago

Forgot to say: if the output of Processing is treated as temporary. If it is saved on the disk it works nice

#2 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to In Progress

Caused by memory provider rejecting the field with the "/" in its name

#3 Updated by Nyall Dawson over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF