Bug report #18872

Symbol Selector Window 'overflows' the screen on small resolutions

Added by Bien Carlos Manazares about 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:3.2 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26704

Description

At a resolution of 1280x720, the symbol selector window tends to be larger than the screen when the symbol fill type is set to 'SVG Fill', as seen in the picture below. It is impossible to scale the window to fit when the categorization type is set to 'single symbol' or 'categorized'. However, it is possible to scale the window when it overflows if the categorization type is set to 'rule-based'.

windowSize_ko.gif - Symbol selector window (366 KB) Alessandro Sarretta, 2018-10-29 12:23 AM

windowSize_ok.gif - Edit rule window (779 KB) Alessandro Sarretta, 2018-10-29 12:23 AM


Related issues

Duplicated by QGIS Application - Bug report #20481: Symbol SVG window Closed 2018-11-13

Associated revisions

Revision cd28b459
Added by Matthias Kuhn over 1 year ago

Merge pull request #8391 from karomap/master

Fixes #18872 Fix symbol selector dialog overflows the screen on small resolution

History

#1 Updated by Harrissou Santanna about 2 years ago

I think this issue should be fixed by https://github.com/qgis/QGIS/pulls/5976 (switching from a widget to a real resizable dialog); i just need time, some learning and a working build environment to finish it.

#2 Updated by Harrissou Santanna about 2 years ago

The fix has been merged in master. Could be nice if you can give it a try and confirm it works so that it gets backported to 3.0. Thanks

#3 Updated by Bien Carlos Manazares about 2 years ago

Harrissou Santanna wrote:

The fix has been merged in master. Could be nice if you can give it a try and confirm it works so that it gets backported to 3.0. Thanks

How do I do that?

#4 Updated by Harrissou Santanna over 1 year ago

  • Status changed from Open to Feedback

Sorry to not have replied to you earlier.
Is this issue still available in 3.2?

#5 Updated by Bien Carlos Manazares over 1 year ago

Harrissou Santanna wrote:

Sorry to not have replied to you earlier.
Is this issue still available in 3.2?

Hello. The issue is still present in 3.2. In fact it seems to have worsened, as resizing the window now results in it disappearing completely and locking me out of the program, forcing me to force-quit it via task manager.

#6 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Feedback to Open
  • Category changed from Editing to GUI
  • Affected QGIS version changed from 3.0.2 to 3.2

#7 Updated by Ryan Dalton over 1 year ago

This is still a real issue for users of small screens. I'm running into this problem using QGIS 3.2.3 on Windows 10, 14-inch laptop with a max resolution of 1366x768. This is definitely a regression from 2.8. The workaround of using rule-based was successful.

#8 Updated by Hanif Rifai over 1 year ago

Adding QScrollArea as main container or stackedWidget container in qgssymbolselectordialogbase.ui will fix the problem.
I've tested on my custom build.

#9 Updated by Giovanni Manghi over 1 year ago

Hanif Rifai wrote:

Adding QScrollArea as main container or stackedWidget container in qgssymbolselectordialogbase.ui will fix the problem.
I've tested on my custom build.

can you propose a pull request?

#10 Updated by Alessandro Sarretta over 1 year ago

I confirm the issue, just tested in QGIS 3.5.0-Master.
I'm not sure this can help but, while the issue happens with the "Symbol selector" window, it doesn't in the "Edit rule" window, accessed through the menu Properties (see the two short animated gifs attached).
Ale

#11 Updated by Hanif Rifai over 1 year ago

Giovanni Manghi wrote:

can you propose a pull request?

I need to test it on macos and linux first

Pull request submitted https://github.com/qgis/QGIS/pull/8391

#12 Updated by Anonymous over 1 year ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

#13 Updated by Ryan Dalton over 1 year ago

Confirmed was resolved in 3.5.13 on a on Windows 10, 14-inch laptop with a max resolution of 1366x768. Great work!

#14 Updated by Jürgen Fischer over 1 year ago

Also available in: Atom PDF