Bug report #18726

geopackage: real values displayed wrong in table

Added by Luca Lanteri about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:DB Manager
Affected QGIS version:3.1(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:26613

Description

1. create a new geopackage layer with an attribute of type "real"
2. insert some point with decimal value
3. open the table
4. the value are displayed wrong, eg: 5.2 became 5.019999999996

See attached example

1.jpg (17.3 KB) Luca Lanteri, 2018-04-15 11:25 PM

2.jpg (32.4 KB) Luca Lanteri, 2018-04-15 11:25 PM

test.gpkg (116 KB) Luca Lanteri, 2018-04-15 11:26 PM

qgis-gpkg-issue.png (132 KB) Alessandro Pasotti, 2018-06-11 05:32 PM

History

#1 Updated by Alessandro Pasotti almost 2 years ago

  • Category changed from Data Provider to DB Manager

#2 Updated by Alessandro Pasotti almost 2 years ago

  • Assignee set to Alessandro Pasotti
  • Status changed from Open to Feedback
  • File qgis-gpkg-issue.png added

I cannot reproduce on current master (see attachment)

#3 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF