Bug report #18674

Display of NULL values of attributes of type INTEGER not correct when coming from WFS

Added by Manuel K about 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:26562

Description

NULL Values of attributes of type INT are incorrectly displayed as "0" instead of the representation for NULL values defined in the Settings/Options Dialog.

http://go.geozug.ch/Zug_WFS_Baumkataster/service.svc/get?SERVICE=WFS&VERSION=2.0.0&REQUEST=DescribeFeatureType&TYPENAME=Baumkataster_ZugType

null_value_int.png (127 KB) Manuel K, 2018-04-09 06:02 PM

snapshot_qgis3.1.png (154 KB) Even Rouault, 2018-05-31 12:02 PM

snip_20181122145131.png (20.8 KB) Frode Hansen, 2018-11-22 02:50 PM

History

#1 Updated by Even Rouault almost 2 years ago

I can't reproduce with QGIS 3.1. The NULL values are properly displayed. See snapshot_qgis3.1.png

#2 Updated by Even Rouault almost 2 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

#3 Updated by Frode Hansen over 1 year ago

Using qgis 3.4.1, when displaying attributes of type INT via WFS 1.1.0, NULL values is displayed as "0". WFS does not transmit nodes with null values, and qgis should not interpret these as "0". Reproduced both in qgis 2.18.25 (LTS) and 3.4.1 on different machines here.

Also available in: Atom PDF