Bug report #18609

Features disappearing when zooming and panning

Added by Ed B over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Canvas
Affected QGIS version:2.18.17 Regression?:No
Operating System:Windows 7 64bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:26497

Description

Hello,
When I use a certain shapefile in Qgis 2.18.18 some of the features disappear and reappear when zooming or panning. The strange thing is they do appear in the attribute table even though they do not appear on the map. The features in the images are manholes and pipes and all the manholes (points) should have connecting pipes.

I can't share this file here but if you email me I will share it with a developer.

Capture2.PNG (13.9 KB) Ed B, 2018-04-02 03:30 PM

Capture.PNG (28.4 KB) Ed B, 2018-04-02 03:30 PM

History

#1 Updated by Nyall Dawson over 2 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

This is usually caused by a corrupt spatial index. Delete the SBX and SBN files from your shapefile and reload the data.

#2 Updated by Ed B over 2 years ago

It was actually a QIX file that was causing my issue. Would there be someway to detect this file and ignore it if things didn't match?

Also available in: Atom PDF