Bug report #18543

'Select features by value' QGIS crashes

Added by Enrico Fiore about 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.18.20 Regression?:No
Operating System:windows 8 64 bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26431

Description

If you active "Select features by value" tool to perform a research in a layer and then you try to edit the same layer, QGIS crashes.

History

#1 Updated by Stephen Knox over 1 year ago

Is this still an issue? I am unable to reproduce in 3

#2 Updated by Enrico Fiore over 1 year ago

In QGIS 3 it is resolved, but in qgis 2.18.20 it is not resolved.

#3 Updated by Giovanni Manghi over 1 year ago

  • Affected QGIS version changed from 2.18.17 to 2.18.20
  • Status changed from Open to Feedback

can you test with the latest 2.18?

#4 Updated by Enrico Fiore over 1 year ago

I tested and the issue is not resolved in the 2.18.25

#5 Updated by Enrico Fiore over 1 year ago

  • Status changed from Feedback to Open

#6 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Enrico Fiore wrote:

I tested and the issue is not resolved in the 2.18.25

try with no (installed or enabled) 3rd party plugins, attach a sample project with data and exact steps to replicate.

#7 Updated by Nyall Dawson over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

This works correctly in 3.4

Also available in: Atom PDF