Bug report #18541

Fixed Distance Buffer makes 0 (zero) distance invalid

Added by Steve Lowman about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:2.18.17 Regression?:Yes
Operating System:W10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:26429

Description

I do a fixed-distance buffer on a polygon layer with the distance parameter as 0.0 (zero). This fails because 0 (zero) is classed as an invalid distance.

In older QGIS versions, and in the OGR 'Buffer Vectors' algorithm, this works well, and I have often used it as a method to remove most types of invalid geometry. Therefore, I think this is a regression.

zero_distance_fixed_buffer_log.txt Magnifier (2.15 KB) Steve Lowman, 2018-03-26 12:41 PM

History

#1 Updated by Nyall Dawson about 2 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

This is not a qgis bug, it's a bug in SAGA.

You could try the other buffer algorithms such as the native QGIS "fixed distance buffer" algorithm instead.

#2 Updated by Steve Lowman about 2 years ago

Thank you, yes, I was testing the tool in the wrong list. I was trying to test whether the native tool can work on features with invalid geometry. It cannot (see #17291), so I think it is best to use the OGR buffer tool for fixed distance, and perhaps the Saga one for variable distance buffers.

I wonder whether I should make a feature request to replace the native buffer tools in the Vector menu for QGIS 2, due to the outcome of #17291?

Also available in: Atom PDF