Bug report #18535

[osx][layouts] "Page Setup" and "Print..." not doing anything

Added by jb Peter over 2 years ago. Updated over 1 year ago.

Status:Open
Priority:Normal
Assignee:-
Category:mac_os_specific
Affected QGIS version:3.6.0 Regression?:No
Operating System:OS X El Captain Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26423

Description

I am not able to open the "Page Setup" and "Print..." windows on QGIS 3.0.0-3 layout window. Nothing happen when I click on these menu items.

History

#1 Updated by Nyall Dawson over 2 years ago

  • Subject changed from QGIS 3.0.0-3 Layout - "Page Setup" and "Print..." not doing anything to [osx][layouts] "Page Setup" and "Print..." not doing anything

Can't confirm on a non-OSX build. Likely an OSX specific issue.

#2 Updated by jb Peter over 2 years ago

I did a bit more of research:

Command line shows a warning: "Warning: QPageSetupDialog: Cannot be used on non-native printers"

Could it be related to this post:
https://bugreports.qt.io/browse/QTBUG-28658

#3 Updated by Erik Marsh about 2 years ago

I can confirm this bug for Mac OS 10.13.5 (High Sierra) and QGIS 3.2. The "Page Setup" and "Print..." do not do anything. Same thing if I right click the print composer and select "Page properties..."

#4 Updated by s e over 1 year ago

I have the same problem with QGIS 3.4 under Arch Linux. "Page Setup" and "Print..." do not do anything. Same warning at command line.

#5 Updated by Giovanni Manghi over 1 year ago

  • Category changed from Actions to Map Composer/Printing
  • Priority changed from High to Normal

#6 Updated by G GIS over 1 year ago

I'm also having this problem, on Mac OS 10.14. With QGIS 3.4.4 and QGIS 3.6.0, selecting "Page Setup" or "Print" in the Layout menu in the Layout window doesn't do anything. If a project uses WMS layers, then after selecting Layout->Print a "Project Contains WMS Layers" notice pops up; clicking Close also leads to nothing happening. I've also tried "Page Setup" and "Print" on Layout for projects that don't have WMS layers and still nothing happens.

I tried QGIS 3.6.0 on Windows 10 and "Page Setup" and "Print" open the expected system dialog windows on that.

Looking through the source code, it appears that QT's QPrinter is used -- perhaps there's an issue with it on Mac OS.

Looking at console.app, this is logged after selecting either "Page Setup" or "Print" in a layout:
QGIS (LaunchServices)
27366555: RECEIVED OUT-OF-SEQUENCE NOTIFICATION: 401 vs 3096, 512, <private>

#7 Updated by Giovanni Manghi over 1 year ago

  • Affected QGIS version changed from 3.0.0 to 3.6.0
  • Category changed from Map Composer/Printing to mac_os_specific

Also available in: Atom PDF