Bug report #18534

QGIS 3.0 atlas does not export correctly in image (portrait / landscape)

Added by salvatore fiandaca about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:3.0.0 Regression?:No
Operating System:win 10 64b Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26422

Description

I have created an atlas in which the page orientation (horizontal / vertical) depends on the geometry of the covering vector (@atlas_geometry);
exporting to pdf I get the expected result, while exporting as an image (PNG) I get some resized images; I attach screenshots

data and project:
https://mega.nz/#!kY41XayT!ZrytL2GGwvZ2nIVxAuf_NqBURnkB0-paYDnae22q3qg

exporting_pdf-jpg.jpg (241 KB) salvatore fiandaca, 2018-03-25 02:20 PM

exporting_png.jpg (204 KB) salvatore fiandaca, 2018-03-25 02:21 PM

Associated revisions

Revision 2aa2ef48
Added by Nyall Dawson almost 2 years ago

[layouts] Fix data defined page sizes sometimes lead to incorrect
created atlas image sizes

Because the exporter prefers to use the image size when it's
specified (as is done in QGIS app), we need to ignore this
when the aspect ratio of that size doesn't match the aspect
ratio of the page to render.

Fixes #18534

History

#1 Updated by Nyall Dawson almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF