Bug report #18525

represent_value fails in QGIS atlas printing mode

Added by Andreas Neumann over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.1(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26413

Description

This concerns atlas printing (layout).

When using the expression represent_value(fieldname) in the context of a relation reference widget, the preview in the expression builder works fine - but on the layout the internal code is displayed instead of the display value text.

See screenshot attached.

Needs to be backported to QGIS 3.0x as well.

Thanks for having a look at this. Thanks!

qgis_map-composer_rel_ref_widget_represent_value-problem.png (103 KB) Andreas Neumann, 2018-03-23 03:14 PM

Associated revisions

Revision 8b59bdcc
Added by Nyall Dawson over 2 years ago

[layouts] Fix missing layer scope for atlas enabled items

Fixes #18525

Revision 842ec80a
Added by Nyall Dawson over 2 years ago

[layouts] Fix missing layer scope for atlas enabled items

Fixes #18525

(cherry-picked from 8b59bdc)

History

#1 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

I can't reproduce. Can you make a demo project which shows this issue?

#2 Updated by Nyall Dawson over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed

Also available in: Atom PDF