Bug report #18503

QGIS Crashed

Added by Ricardo Campos about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Unknown
Affected QGIS version:3.0.0 Regression?:No
Operating System:win7 64bits Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:26391

Description

User Feedback

Report Details

Crash ID: 69eb2b3edbeb282272e29c4fc56823e6bcdad5c6

Stack Trace

geos::index::strtree::STRtree::STRIntersectsOp::~STRIntersectsOp :
QgsGeos::offsetCurve :
QgsGeometry::offsetCurve :
QgsSymbolLayerUtils::needSvgMarker :
QgsSimpleLineSymbolLayer::renderPolyline :
QgsLineSymbol::renderPolylineUsingLayer :
QgsLineSymbol::renderPolyline :
QgsSymbol::renderFeature :
QgsFeatureRenderer::renderFeature :
QgsVectorLayerLabelProvider::registerFeature :
QgsVectorLayerLabelProvider::registerFeature :
QgsMapRendererParallelJob::renderLayerStatic :
QgsMapRendererParallelJob::renderingFinished :
QgsArchive::zip :
QgsImageOperation::flipImage :
QtConcurrent::ThreadEngineBase::run :
QThreadPoolPrivate::reset :
QThread::start :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.0-Girona
QGIS code revision: 001c80b0c3
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.3
Running against GDAL: 2.2.3

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.1.7601

History

#1 Updated by Nyall Dawson about 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #14752 (same root issue)

Also available in: Atom PDF