Bug report #18477

QGIS 3 "unable to save auxiliary storage"

Added by R L over 1 year ago. Updated 9 months ago.

Status:Feedback
Priority:High
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:3.4.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26365

Description

Using QGIS 3, upon attempting to save the loaded project, I'll get the message "unable to save auxiliary storage" and the saving will be unsuccessful.

It doesn't have happen every time I use the program, but I can't isolate anything different about the times it does.

nevada_county_roads.zip (9.22 KB) Tom Grundy, 2018-10-05 05:41 PM

Road_Centerlines.zip (2.83 MB) Tom Grundy, 2018-10-05 05:41 PM


Related issues

Duplicated by QGIS Application - Bug report #20828: Unable to save project / auxiliary storage Closed 2018-12-18

History

#1 Updated by Brendan Heberlein over 1 year ago

I also have experienced this issue. Running Mac OS 10.13.3 on Early 2015 MacBook Pro Retina.

#2 Updated by Cameron MacIver over 1 year ago

I have the same issue. running an iMac with os 10.13.4

#3 Updated by Harrissou Santanna over 1 year ago

  • Operating System deleted (Windows 10)

Given the different OS concerned i remove the OS mention.
When it occurs, does it really prevent you to save the auxiliary storage data (hence you lose your work) or is it simply a message with no effects?

#4 Updated by Tommy Wahlund over 1 year ago

Same issue. Qgis 3.0.2 (revision 307d082e3d). Windows 10. Could not isolate a reason to it either, since it only happens now and then.
The file got saved thought, so in my case the message was without effect.

#5 Updated by Calvin Thompson over 1 year ago

I've experienced this issue on 2.18.16 and now 3.0.2. I often leave qgis running as I add new client properties for my lawn care company. If I forget to save this can be a nuisance since I'll have to reload all the shape files.
Just now it happened again in 3.02, however I ended task in task manager hoping an automatic backup would save me. When I reopened it was up to date. Don't know if it has no effect in 3.02 or not, but there definitely was a small panic thinking I was going to have to recreate my project file again.
Win 10

#6 Updated by Adam Stewart over 1 year ago

Also encountered this on macOS 10.13.5 with QGIS 3.2.0. Unfortunately, I have no additional info on how to reproduce it. It affects both Save and Save As. Before I tried to save, I tried to quit and it asked me if I wanted to save my changes. After seeing the error message, it no longer complained when I tried to quit, so I assume this means it actually saved and the error message is a red herring.

#7 Updated by Madeline Chmielinski over 1 year ago

Encountered this on macOS 10.12.6. QGIS did not save but I was able to work around this by saving as .qgs instead of the default .qgz

#8 Updated by Mars Sjoden over 1 year ago

QGIS version 3.2.0-Bonn
Mac 10.12.6

Same issue. Even though the same project has been saved to the same location before, this morning the error window popped up:

"unable to save auxiliary storage"

Saving as .qgs worked.

#9 Updated by Giovanni Manghi over 1 year ago

  • Affected QGIS version changed from 3.0.0 to 3.2
  • Category changed from Unknown to Project Loading/Saving

#10 Updated by Kim Frankcombe over 1 year ago

Same issue on Ubuntu 16.04 with QGIS 3.2.1. Tried save, save as, tried saving to /tmp where I know write permissions would not be an issue all no good. Change the files type to .qgs and it all worked fine. Curious that the file I originally opened was a qgs file so not sure why it wanted to change to .qgz on plain save. I just tried to repeat my steps but it now saves just fine so I can't reliably reproduce this sorry.

#11 Updated by Giovanni Manghi over 1 year ago

  • Affected QGIS version changed from 3.2 to 3.2.1

#12 Updated by Samuel Wechsler about 1 year ago

I observed same behaviour on Windows and with QGIS3.2 only happend when trying to save to .qgz but not to .qgis (same project).

#13 Updated by Regis Haubourg about 1 year ago

  • Priority changed from Normal to High

#14 Updated by Regis Haubourg about 1 year ago

  • Status changed from Open to Feedback

I just tested under ubuntu 16.04 and Windows 10 with QGIS 3.2.2. I couldn't reproduce. Can someone share a project and a dataset. We maybe have a data specific failure here

#15 Updated by Sebastian Hahn about 1 year ago

I just testet with QGIS 3.2.3 under Windows 10. Saving as qgz still fails because of auxiliary storage. Saving as qgs works.

#16 Updated by Giovanni Manghi about 1 year ago

  • Affected QGIS version changed from 3.2.1 to 3.2.3

#17 Updated by Paul Blottiere about 1 year ago

I did not succeed in reproducing the error, so I opened a PR in order to add a more explicit message: https://github.com/qgis/QGIS/pull/8081.

It's not a bugfix of course, but it will help us to determine the origin of the problem.

#18 Updated by Tom Grundy about 1 year ago

Same issue in 3.2.1 on Windows 10. Simple project (nevada_county_roads) and base data (Road_Centerlines) attached. Maybe a possible clue: it had been saving fine as qgz for quite a while, and after I added some rule-based symbology to Road_Centerlines, it started giving the same message. Changed from .qgz to .qgs and it saves fine. I have not tried to track it down any farther, since I need to move forward on this project with the valid .qgs workaround in place. Thanks

#19 Updated by Nick Hatch about 1 year ago

Paul Blottiere wrote:

I opened a PR in order to add a more explicit message. It's not a bugfix of course, but it will help us to determine the origin of the problem.

Thanks Paul - I think that was really helpful. Just hit this with QGIS 3.4.1-Madeira on macOS 10.12.6, the error message was: "Unable to save auxiliary storage ('Cannot open /var/folders/2l/.../T/QGIS3-duDXtB/ProjectName.qgd for input')"

I first hit this issue with QGIS 3.2.x(1?) on OS X with a long-running open project, and lost a lot of work. Upgraded to 3.4.1-Madeira - and was really cautious with saving frequently. Was away from the computer for two-weeks, when I came back the computer was in a deep hibernate state with QGIS open. Tried to save and quit, received the error.

Is it possible that the root cause here is the underlying OS cleaning up temporary files out from under QGIS?

#20 Updated by Giovanni Manghi about 1 year ago

  • Affected QGIS version changed from 3.2.3 to 3.4.1

#21 Updated by belg4mit - 11 months ago

I've run into this as well. It definitely does not save the data (the file timestamp remains unmodified), yet the asterisk indicating unsaved data in the window title disappears.

Bug #20828 seems to be a duplicate of this, but it does include a work-around for those encountering it, which might also be included in a revised error dialog: Try saving as QGS instead of QGZ.

#22 Updated by Alister Hood 10 months ago

The error message indicates it is trying to save in the temporary directory e.g. C:/Users/username/AppData/Local/Temp/QGIS3-FaxmiV/
Is it right that it is trying to save there?

#23 Updated by Alister Hood 10 months ago

I guess it saves to the temporary folder and then zips it up.

Does everyone experiencing this hibernate their pc?

#24 Updated by Andreas Olsson 10 months ago

Same problem on Windows 10.

Error message: "Unable to save project C:\*****" -> "Unable to save auxiliary storage ('Cannot open C:/Users/****/AppData/Local/Temp/QGIS3-pbvmYI/*****.qgd for input')"

The folder isnt there, so does it fail to create it??

QGIS 3.4.4-1

It seems to be a difference using .qgs instead of qgz.

#25 Updated by Chris Ford 9 months ago

Had the same problem using 3.4.4 on mac when save as uses .qgs.qgz (suggested) or .qgz (changed to) file type. The project is not saved.

Solved by using a .gqs file type.

#26 Updated by Giovanni Manghi 9 months ago

Also available in: Atom PDF