Bug report #18475

Concave hull error in Qgis 3.0

Added by Pieter Geene over 1 year ago. Updated 7 months ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Processing/Core
Affected QGIS version:3.0.0 Regression?:Yes
Operating System:Windows 10 Easy fix?:Yes
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26363

Description

When trying to create a concave hull around a bunch of vertices in Qgis 3.0 I get an error.

Qgis30 concave hull error.PNG (236 KB) Pieter Geene, 2018-03-18 08:06 PM

Test.gpkg - Test Data (792 KB) Basil Eric Rabi, 2018-03-19 05:40 AM

Associated revisions

Revision 732c5260
Added by Nyall Dawson over 1 year ago

[processing] Fix Concave Hull algorithm, add tests

Fixes #18475

Revision feaf22f9
Added by Nyall Dawson over 1 year ago

[processing] Fix Concave Hull algorithm, add tests

Fixes #18475

(cherry-picked from 732c526)

History

#1 Updated by Nyall Dawson over 1 year ago

  • Assignee changed from Victor Olaya to Nyall Dawson
  • Status changed from Open to In Progress

#2 Updated by Nyall Dawson over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

#3 Updated by Basil Eric Rabi over 1 year ago

Concave (and convex) hull still do not output correctly using the attached data and the patches applied. This may be related to Issue #18219. The attached data can be processed without issues in 2.18.17.

#4 Updated by Johannes Kroeger 7 months ago

Looks like this should have been re-opened back then. BUT I just tried reproducing and had no issues in 3.6 with neither Concave hull (alpha shapes) nor Concave hull (k-nearest neighbor).

Also available in: Atom PDF