Bug report #18426

Form size/location is only remembered for each feature

Added by Damien Smith over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Forms
Affected QGIS version:3.1(master) Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26315

Description

In QGIS 3.X, when doing data entry, the form size and location is reset for every new feature and only remembered for a single feature. This makes data entry very cumbersome particularly for multiple monitors or larger forms. If this is not a bug and people want this behaviour, it should be disabled by default and only available by an option.

e.g.

Remember form settings by -:
Layer or Feature

Associated revisions

Revision bf124046
Added by Nyall Dawson over 2 years ago

Revert 5b9be7a

Since the attribute table dialog object name is set to match
the layer/featureid combo, this commit was causing the attribute
form dialog to remember its position and size for each
feature/layer combo individually.

That's NOT what we want!

Fixes #18426

Revision 7521a82a
Added by Nyall Dawson over 2 years ago

Revert 5b9be7a

Since the attribute table dialog object name is set to match
the layer/featureid combo, this commit was causing the attribute
form dialog to remember its position and size for each
feature/layer combo individually.

That's NOT what we want!

Fixes #18426

(cherry-picked from bf12404)

History

#1 Updated by Nyall Dawson over 2 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • Status changed from Open to In Progress

#2 Updated by Nyall Dawson over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF