Bug report #18367

TypeError when running Vector table tools -> Refactor fields

Added by J Taylor about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.14.22 Regression?:No
Operating System:Ubuntu Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26257

Description

I am converting several fields in a vector layer from type String to Real using the "Refactor fields" tool in the Processing toolbox. When I apply the changes, the process runs to completion and then throws the following error message:

An error has occurred while executing Python code:

TypeError: 'instancemethod' object is not connected
Traceback (most recent call last):
File "/usr/share/qgis/python/plugins/processing/gui/AlgorithmDialog.py", line 265, in closeEvent
QgsMapLayerRegistry.instance().layerWasAdded.disconnect(self.mainWidget.layerAdded)
TypeError: 'instancemethod' object is not connected

Python version: 2.7.12 (default, Dec 4 2017, 14:50:18) [GCC 5.4.0 20160609]
QGIS version: 2.14.22-Essen Essen, exported

Python Path:
/usr/share/qgis/python/plugins/processing
/usr/share/qgis/python
/home/jesse/.qgis2/python
/home/jesse/.qgis2/python/plugins
/usr/share/qgis/python/plugins
/usr/lib/python2.7
/usr/lib/python2.7/plat-x86_64-linux-gnu
/usr/lib/python2.7/lib-tk
/usr/lib/python2.7/lib-old
/usr/lib/python2.7/lib-dynload
/usr/local/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages/PILcompat
/usr/lib/python2.7/dist-packages/gtk-2.0
/usr/lib/python2.7/dist-packages/ubuntu-sso-client
/usr/lib/python2.7/dist-packages/wx-3.0-gtk2
/home/jesse/.qgis2//python
/usr/share/qgis/python/plugins/fTools/[email protected] error has occurred while executing Python code:

TypeError: 'instancemethod' object is not connected
Traceback (most recent call last):
File "/usr/share/qgis/python/plugins/processing/gui/AlgorithmDialog.py", line 265, in closeEvent
QgsMapLayerRegistry.instance().layerWasAdded.disconnect(self.mainWidget.layerAdded)
TypeError: 'instancemethod' object is not connected

Python version: 2.7.12 (default, Dec 4 2017, 14:50:18) [GCC 5.4.0 20160609]
QGIS version: 2.14.22-Essen Essen, exported

Python Path:
/usr/share/qgis/python/plugins/processing
/usr/share/qgis/python
/home/jesse/.qgis2/python
/home/jesse/.qgis2/python/plugins
/usr/share/qgis/python/plugins
/usr/lib/python2.7
/usr/lib/python2.7/plat-x86_64-linux-gnu
/usr/lib/python2.7/lib-tk
/usr/lib/python2.7/lib-old
/usr/lib/python2.7/lib-dynload
/usr/local/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages/PILcompat
/usr/lib/python2.7/dist-packages/gtk-2.0
/usr/lib/python2.7/dist-packages/ubuntu-sso-client
/usr/lib/python2.7/dist-packages/wx-3.0-gtk2
/home/jesse/.qgis2//python
/usr/share/qgis/python/plugins/fTools/tools

... in spite of this, it seems to have successfully created a new layer with the altered field types, and also I can't find any evidence of corrupted data. But I just wanted to figure out why this was happening, because I am worried that something subtle might have gone wrong that will affect things later.

Thanks!

History

#1 Updated by J Taylor about 2 years ago

Sorry, I accidentally pasted the error message twice. It's just:

An error has occurred while executing Python code:

TypeError: 'instancemethod' object is not connected
Traceback (most recent call last):
File "/usr/share/qgis/python/plugins/processing/gui/AlgorithmDialog.py", line 265, in closeEvent
QgsMapLayerRegistry.instance().layerWasAdded.disconnect(self.mainWidget.layerAdded)
TypeError: 'instancemethod' object is not connected

Python version: 2.7.12 (default, Dec 4 2017, 14:50:18) [GCC 5.4.0 20160609]
QGIS version: 2.14.22-Essen Essen, exported

Python Path:
/usr/share/qgis/python/plugins/processing
/usr/share/qgis/python
/home/jesse/.qgis2/python
/home/jesse/.qgis2/python/plugins
/usr/share/qgis/python/plugins
/usr/lib/python2.7
/usr/lib/python2.7/plat-x86_64-linux-gnu
/usr/lib/python2.7/lib-tk
/usr/lib/python2.7/lib-old
/usr/lib/python2.7/lib-dynload
/usr/local/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages/PILcompat
/usr/lib/python2.7/dist-packages/gtk-2.0
/usr/lib/python2.7/dist-packages/ubuntu-sso-client
/usr/lib/python2.7/dist-packages/wx-3.0-gtk2
/home/jesse/.qgis2//python
/usr/share/qgis/python/plugins/fTools/tools

#2 Updated by Alexander Bruy about 2 years ago

  • Status changed from Open to Feedback

2.14 is not supported. Please test with 2.18 and 3.0/3.1

#3 Updated by Alexander Bruy about 2 years ago

  • Status changed from Feedback to Closed

Closed for the lack of feedback. Please reopen if necessary.

Also available in: Atom PDF