Bug report #18352

DB Manager is not showing the result after a SQL query

Added by Etienne Trimaille over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Paul Blottiere
Category:DB Manager
Affected QGIS version:3.1(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26242

Description

On QGIS Master 3.1, after I run a simple query such as `select * from my_table`, the result panel stays empty.

The query works well in QGIS 3.0 and in PgAdmin. But in 3.1, I can guess that the query is running because the panel is disabled while the query is running in the background. But then, the window is reactivated again but the result is not displayed.

It might be related to the display with MacOS?

Screen Shot 2018-03-05 at 11.54.37.png (287 KB) Etienne Trimaille, 2018-03-06 01:22 PM

Associated revisions

Revision 6bdee5b7
Added by Paul Blottiere over 2 years ago

[dbmanager] Fixes empty table
Fixes #18352

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High

#2 Updated by Keith Jenkins over 2 years ago

I don't think it is related to MacOS, since I'm seeing the same problem with QGIS 3.1.0-Master (5b8599e9bb) on Windows.

It works when I run a query via Virtual Layers, but not with PostGIS directly, in which case I see a "Task Complete" notification, but no results.

The following Python error is logged:

WARNING
Traceback (most recent call last):
  File "C:/PROGRA~1/QGIS2~1.18/apps/qgis-dev/./python/plugins\db_manager\dlg_sql_window.py", line 233, in executeSqlCompleted
  if self.modelAsync.task.status() == QgsTask.Complete:
AttributeError: 'NoneType' object has no attribute 'status'

#3 Updated by Regis Haubourg over 2 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • Assignee set to Paul Blottiere

#4 Updated by Paul Blottiere over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#5 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF