Bug report #18349

regression: aggregate algorithm broken under QGIS 3.0 (within model or as standalone alg)

Added by Mathieu Pellerin - nIRV over 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:High
Assignee:Arnaud Morvan
Category:Processing/Core
Affected QGIS version:3.0.0 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26239

Description

The aggregate algorithm is broken when used in a model, under QGIS 3.0/3.1.

Steps to reproduce
  1. Create a new model
  2. Add an aggregate algorithm
  3. Notice the error stack

Associated revisions

Revision ff6ea336
Added by Nyall Dawson about 2 years ago

[processing] Fix broken Aggregate algorithm

Fixes #18349

History

#1 Updated by Mathieu Pellerin - nIRV over 2 years ago

  • Regression? changed from No to Yes
  • Subject changed from aggregate algorithm broken when used in a model to regression: aggregate algorithm broken under QGIS 3.0 (within model or as standalone alg)

Well, turns out the algorithm is broken even outside the context of models.

#2 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High

#3 Updated by Nyall Dawson about 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF