Bug report #18323

Multi-part Polygon is not mapped with shortest segments

Added by Michael Miller over 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Projection Support
Affected QGIS version:2.18.16 Regression?:No
Operating System:Microsoft Windows Pro 10, version 1709 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:26213

Description

I loaded the edna coverage from USGS into QGIS 2.18.16 and the display with Google Physical as backdrop is attached as an image.

The second polygon from the top is not using shortest path segments to construct the internal area (blue). Seems to me like a major issue if its occurrence within the program is unpredictable.

ednaPolygons.png - Rendered map (226 KB) Michael Miller, 2018-03-03 08:46 PM

tatuk.png - shp in tatuk viewer (22 KB) Michael Miller, 2018-03-03 10:10 PM

ge.png - kml in Google Earth (503 KB) Michael Miller, 2018-03-03 10:11 PM


Related issues

Duplicates QGIS Application - Bug report #13380: reprojection of lat/long lines across 180 in mercator map... Closed 2015-09-18

History

#1 Updated by Michael Miller over 2 years ago

Revision: I misunderstood what I saw earlier. After opening the same file in Tatuk viewer, it looks like the big polygon over Alaska and the small triangle over Siberia are not being separated properly, because they appear to be combined by QGIS into a single polygon. The file is available from the USGS at
https://dds.cr.usgs.gov/ee-data/coveragemaps/shp/ee/edna/edna.zip

#2 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from High to Normal
  • Assignee deleted (Victor Olaya)
  • Category changed from Processing/Modeller to Projection Support

Michael Miller wrote:

Revision: I misunderstood what I saw earlier. After opening the same file in Tatuk viewer, it looks like the big polygon over Alaska and the small triangle over Siberia are not being separated properly, because they appear to be combined by QGIS into a single polygon. The file is available from the USGS at
https://dds.cr.usgs.gov/ee-data/coveragemaps/shp/ee/edna/edna.zip

the problem is a projection one, you have features crossing the dateline, and they are always a pain. I'm sure there is/are other tickets about it, please try do a search, if you find any close this as duplicate.

#3 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback

#4 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to duplicate

Duplicate of #13380

#5 Updated by Jürgen Fischer about 2 years ago

  • Duplicates Bug report #13380: reprojection of lat/long lines across 180 in mercator map fails added

Also available in: Atom PDF