Bug report #18308

Invalid WFS-Transaction Update request

Added by Martin Kofahl almost 3 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:3.0.0 Regression?:No
Operating System:Windows x86_64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26199

Description

An WFS-T update request generated with QGIS 3.0.0 uses the xml attribute name "typeNames" in the "Update" tag. According to the specification, "typeName" should be used for updates.

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Status changed from Open to Feedback

Does 2.18 behave the same way?

#2 Updated by Martin Kofahl almost 3 years ago

  • Status changed from Feedback to Open

No, 2.18 correctly uses "typeName" as xml attribute name. However, 2.18 fails because auf #17945 (also relevant for 3.0).

#3 Updated by Even Rouault over 2 years ago

  • Resolution set to fixed/implemented

I believe this should be fixed now in master since https://github.com/qgis/QGIS/commit/7511d1ffdb867f3bd19bf0697afa5c49ae6b621d

#4 Updated by Even Rouault about 2 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF