Bug report #18227

GeoReferencer crash

Added by Andrew Shanin over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:C++ plugins/Georeferencer
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:26118

Description

User Feedback

Use georeferencer

Report Details

Crash ID: fd2a65aecc93b39c1c9e241e65339e19926bb8e0

Stack Trace

QSortFilterProxyModel::parent :
QSortFilterProxyModel::mapToSource :
std::basic_string<char,std::char_traits<char>,std::allocator<char> >::capacity :
QMetaObject::activate :
QWidget::customContextMenuRequested :
QWidget::event :
QFrame::event :
QAbstractItemView::viewportEvent :
QCoreApplicationPrivate::sendThroughObjectEventFilters :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QSizePolicy::QSizePolicy :
QSizePolicy::QSizePolicy :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QGuiApplicationPrivate::processMouseEvent :
QWindowSystemInterface::sendWindowSystemEvents :
QEventDispatcherWin32::processEvents :
CallWindowProcW :
DispatchMessageW :
QEventDispatcherWin32::processEvents :
qt_plugin_query_metadata :
QEventLoop::exec :
QCoreApplication::exec :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.0-Girona
QGIS code revision: 001c80b0c3
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.3
Running against GDAL: 2.2.3

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.16299

History

#1 Updated by João Gaspar over 2 years ago

hi,
Can you describe the steps that give this error?
You can attach screenshots as well.

Regards

#2 Updated by Giovanni Manghi over 2 years ago

  • Category changed from Rasters to C++ plugins/Georeferencer
  • Status changed from Open to Feedback
  • Crashes QGIS or corrupts data changed from No to Yes

#3 Updated by Andrew Shanin over 2 years ago

João Gaspar wrote:

hi,
Can you describe the steps that give this error?
You can attach screenshots as well.

Regards

then delete points

#4 Updated by Giovanni Manghi over 2 years ago

then delete points

?

#5 Updated by Gerhard Spieles over 2 years ago

I can confirm this behavior.
Mostly, crashes happens when you work hurry by zoom in/out or pan multiple.
You can reduce crashes significant, when you work slow and wait until the raster is complete refreshed before start a new zoom or pan.

#6 Updated by Giovanni Manghi over 2 years ago

Gerhard Spieles wrote:

I can confirm this behavior.
Mostly, crashes happens when you work hurry by zoom in/out or pan multiple.
You can reduce crashes significant, when you work slow and wait until the raster is complete refreshed before start a new zoom or pan.

only on qgis 3?

#7 Updated by Gerhard Spieles over 2 years ago

2.xx also.

#8 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Feedback to Open

#9 Updated by Alexis Polti over 2 years ago

A PR has been submitted.

#10 Updated by Regis Haubourg over 2 years ago

Can you point a link to the relevant PR please?

#11 Updated by Regis Haubourg over 2 years ago

OK found one here: https://github.com/qgis/QGIS/pull/6626

It has been merged in master. Any chance to have this backported since it seems to concern 2.18 also?

#12 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#13 Updated by Nyall Dawson over 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to no timely feedback

Also available in: Atom PDF