Bug report #18192

vertex editor doesn't honour topological editing when moving a segment

Added by Regis Haubourg over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Martin Dobias
Category:Digitising
Affected QGIS version:3.3(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26083

Description

When selecting a segment, not a serie of vertices, the topological editing fails to move shared borders together.
It worked in 2.18.
There is a workaround by selection the nodes and grab nodes instead of grabing the segment.

See animation gif

topological_editing_segment.gif (1.63 MB) Regis Haubourg, 2018-02-23 02:02 PM


Related issues

Related to QGIS Application - Bug report #18046: Adding new vertices ignores topological editing Closed 2018-02-05
Related to QGIS Application - Bug report #17331: new node tool topological editing Closed 2017-10-25
Duplicated by QGIS Application - Bug report #20226: vertex edit ignore topological editing when move a polygo... Closed 2018-10-26

History

#1 Updated by Andreas Wicht about 2 years ago

maybe connected, but at least in the same scope: #18046

#2 Updated by Harrissou Santanna over 1 year ago

  • Regression? changed from No to Yes

Still occurs in master (3.3)

#3 Updated by Harrissou Santanna over 1 year ago

  • Related to Bug report #18046: Adding new vertices ignores topological editing added

#4 Updated by Harrissou Santanna over 1 year ago

#5 Updated by Giovanni Manghi over 1 year ago

  • Affected QGIS version changed from 3.0.0 to 3.3(master)

Confirmed on the latest master.

#6 Updated by Bernhard Ströbl over 1 year ago

  • Status changed from Open to Feedback

This seems fixed in master (3.5.0), could you please check and either close or change the affected QGIS version?

#7 Updated by Martin Dobias over 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Yes this is the same bug as #20226 which has been fixed in https://github.com/qgis/QGIS/pull/8413

#8 Updated by Martin Dobias over 1 year ago

  • Duplicated by Bug report #20226: vertex edit ignore topological editing when move a polygon boundary segment added

Also available in: Atom PDF