Bug report #18190

vertex editor don't honour topological editing when used with a feature selection AND a node selection

Added by Regis Haubourg over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:Martin Dobias
Category:Digitising
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26081

Description

Since a few hours before the release, vertex editor now has a priority over the selected feature so that it is possible to force the vertex selection for one particular feature and avoid selecting nodes of neighbour.

This new mode has an issue when used with topological editing. The set of vertices moved doesn't have the neighbour nodes following, except for the grabbed node.
See gif animations attached for a clearer explanation!

vertex_editor_no_selectedfeat_with_topoedit_on.gif (1.49 MB) Regis Haubourg, 2018-02-23 01:30 PM

vertex_editor_one_selectedfeat_without_topoedit_on.gif (1.8 MB) Regis Haubourg, 2018-02-23 01:30 PM

vertex_editor_one_selectedfeat_with_topoedit_on.gif - The scenario with the issue (2.56 MB) Regis Haubourg, 2018-02-23 01:30 PM

vertex_editor_two_selectedfeat_with_topoedit_on.gif (1.72 MB) Regis Haubourg, 2018-02-23 01:30 PM


Related issues

Duplicated by QGIS Application - Bug report #20158: Moving segments after range selection of vertices destroy... Closed 2018-10-18

History

#1 Updated by Bernhard Ströbl over 1 year ago

  • Status changed from Open to Feedback

This seems to be fixed in current master (3.5.0). Could you please check and either close or change the affected QGIS version?

#2 Updated by Martin Dobias over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

This is the same bug as #20158 and also fixed by https://github.com/qgis/QGIS/pull/8413

#3 Updated by Martin Dobias over 1 year ago

  • Duplicated by Bug report #20158: Moving segments after range selection of vertices destroys topology added

Also available in: Atom PDF