Bug report #18183

QGIS 3: SAGA "output extent" should not be mandatory

Added by Giovanni Manghi about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/SAGA
Affected QGIS version:3.0.0 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26074

Description

It isn't mandatory in QGIS <=2.18.

Moreover it seems that if choosing an output extent, for example using one of inputs extents, then the xmin/xmax ymin/ymax coordinates are not correctly sorted, needing to move the third value to the second place.

saga-mosaic2.jpg (34.5 KB) Brad Kanther, 2018-03-09 02:49 PM

saga-mosaic3.jpg (7.95 KB) Brad Kanther, 2018-03-09 02:49 PM

saga-mosaic1.jpg (149 KB) Brad Kanther, 2018-03-09 02:49 PM

Associated revisions

Revision 23172a10
Added by Salvatore Larosa about 2 years ago

[processing] Fixes #18183: SAGA "output extent" should not be mandatory

Revision 88e8acdd
Added by Alexander Bruy about 2 years ago

Merge pull request #6571 from slarosa/fix_18183

[processing] SAGA "output extent" should not be mandatory (fix #18183)

History

#1 Updated by Giovanni Manghi about 2 years ago

  • Subject changed from QGIS master: SAGA "output extent" should not be mandatory to QGIS 3: SAGA "output extent" should not be mandatory

#2 Updated by Giovanni Manghi about 2 years ago

  • Affected QGIS version changed from master to 3.0.0

#3 Updated by Jean Hemmi about 2 years ago

The problem is on under 3.0.0-Girona 001c80b0c3

#4 Updated by Victor Olaya about 2 years ago

Which algorithm are you trying?

The extent params are not optional by the default. They should be in most cases (but not in others like the "Create graticule" algorithm), so it makes sense to change that

However, i am not seeing the wrong behaviour of extents that you mention. It works fine here if using the extent from a layer. The coords are written xmin,xmax,ymin,ymax, and that's the order in which they are described in the algorithms (unless it is wrongly declared in the one you are trying)

#5 Updated by Giovanni Manghi about 2 years ago

Victor Olaya wrote:

Which algorithm are you trying?

The extent params are not optional by the default. They should be in most cases (but not in others like the "Create graticule" algorithm), so it makes sense to change that

However, i am not seeing the wrong behaviour of extents that you mention. It works fine here if using the extent from a layer. The coords are written xmin,xmax,ymin,ymax, and that's the order in which they are described in the algorithms (unless it is wrongly declared in the one you are trying)

I was trying "universal kriging". The "outout extent" parameter is not mandatory for the same tool in 2.18. Maybe other SAGA tools are affected.

#6 Updated by Brad Kanther about 2 years ago

I also noticed this using "Mosaic Raster Layers". Usually you get the [Leave Blank to use min covering extent] in grey text. This doesn't seem to be an option even in 3.0.

See screenies below. Maybe installation error?

#7 Updated by Salvatore Larosa about 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF