Bug report #18098

QGIS Master build b6ad920404: Flags for Layers in a group don't works properly

Added by Antonio Viscomi over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:Yes
Operating System:Windows 7 x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:25994

Description

Hi All,
I noticed that in 2.99 version:
1) When I have a group layer with the elements in, not flagged:
- I go to flag only the group then, the elements in remain not flagged and nothing appear on the Canvas (attached screenshot Group flag1);
2) Also in case of elements of a group flagged (screenshot Group flag2):
- I go to de-flag the group with elements in flagged then the elements remain flagged, but in this case, the elements disappear from Canvas correctly (screenshot Group flag3)

Best Regards

Group flag1.png (165 KB) Antonio Viscomi, 2018-02-14 07:42 AM

Group flag3.png (141 KB) Antonio Viscomi, 2018-02-14 07:42 AM

Group flag2.png (996 KB) Antonio Viscomi, 2018-02-14 07:42 AM

History

#1 Updated by Nyall Dawson over 2 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

This is by design in 3.0 - it allows a group to be toggled without resetting the checked layers inside that group.

You can ctrl+click the group to emulate the 2.x behaviour.

Also available in: Atom PDF