Bug report #18057

Override typographic ligatures when letter spacing > 0

Added by Nathan Perry almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:2.18.15 Regression?:No
Operating System:Mac OS 10.13.2 Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:25953

Description

When rendering labels using a font that employs typographic ligatures, QGIS does not disable the ligatures when letter spacing is greater than zero. The result is that these letters remain closely spaced because they are displayed as a single glyph.

See attached images, where the font is Arno Pro and letter spacing is set to 5.

Screen Shot 2018-02-07 at 4.48.59 PM.png - Ligature 'tt' (11.3 KB) Nathan Perry, 2018-02-07 11:10 PM

Screen Shot 2018-02-07 at 4.48.07 PM.png - Ligature 'TT' (14.3 KB) Nathan Perry, 2018-02-07 11:10 PM

Screen Shot 2018-02-07 at 4.54.50 PM.png - Ligature 'fi' (10.4 KB) Nathan Perry, 2018-02-07 11:10 PM

Screen Shot 2018-02-07 at 4.56.56 PM.png - Ligature 'ffi' (10.7 KB) Nathan Perry, 2018-02-07 11:10 PM

History

#1 Updated by Mathieu Pellerin - nIRV almost 2 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

This is an issue with the Qt library, which you'll be happy to know is fixed in Qt 5, which we know use in upcoming QGIS 3.0.

Also available in: Atom PDF