Bug report #18018

a virtual layer make the project empty

Added by Lee Han over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Virtual Layers
Affected QGIS version:2.18.16 Regression?:No
Operating System:windows 7 64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:25914

Description

It is not the first time I encounter this issue.(It is been around a lot by the way.)
My qgis project has some postgis and shapefile layers plus a virtual_layer.
Open the project : it is empty, nothing in the list or in the canevas
Edit the .qgs, remove the <maplayer>...</maplayer> concerning the virtual_layer.
open again the .qgs and the project is ok.

Sometimes I can work with many virtual layers during days or weeks and suddenly, I don't know the reason why, the project may become empty.
I have tested this with different computers, same behaviour. This has been going on since virtual layers were added (to my knowledge).
Copy of project attached.

plan_virtual_layer.qgs (155 KB) Lee Han, 2018-02-01 10:33 AM

History

#1 Updated by Enrico Fiore about 2 years ago

I have noticed the same issue in QGIS 2.18.17.
If there is one or more virtual layers that refers to layers that are been renamed or removed, QGIS project will be loaded empty.

#2 Updated by Regis Haubourg over 1 year ago

  • Resolution set to not reproducable
  • Priority changed from High to Normal
  • Status changed from Open to Feedback

Could you provide a sample project file with data that allows to reproduce the issue. It tried to reproduce with no success here. (This is the hardest part in fixing such issues, making the condition reproducible for itself, and then for others).

Did you try QGIS 3.x to test future 3.4 LTR ?

#3 Updated by Lee Han over 1 year ago

I don't have any project file with the "bug" for now. If it happens, I will join it.
I am working with QGis 3.4 now. We'll see.

#4 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF