Bug report #17948

“Coordinate Reference System Selector” query/window after processing.run()

Added by Mike Blechschmidt almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/OGR
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25844

Description

Convert a DXF with processing(plugin)
@processing.run('gdal:convertformat',{'INPUT':'d:/tar/mytest.dxf','OPTIONS':'','OUTPUT': 'c:/../x.shp'})

The query of the CRS is absolutely superfluous, since no transformation should take place and also no projection file must be written.

The code for QGIS 2.xx
processing.runalg('gdalogr:convertformat','d:/tar/mytest.dxf‌​',0,None,'c:/../x.shp')
works without Problems (without window)

Associated revisions

Revision 22de2511
Added by Nyall Dawson almost 3 years ago

[processing] Correctly supress CRS selector dialog when testing
input layer validity

TODO: we NEED a non-hacky way to supress this dialog and allow
invalid CRS for layers!

Fixes #17948

History

#1 Updated by Mike Blechschmidt almost 3 years ago

  • Assignee deleted (Victor Olaya)

Convert a DXF with processing(plugin)
processing.run('gdal:convertformat',{'INPUT':'d:/tar/mytest.dxf','OPTIONS':'','OUTPUT': 'c:/../x.shp'})

The query of the CRS is absolutely superfluous, since no transformation should take place and also no projection file must be written.

The code for QGIS 2.xx
processing.runalg('gdalogr:convertformat','d:/tar/mytest.dxf‌​',0,None,'c:/../x.shp')
works without Problems (without window)

#2 Updated by Nyall Dawson almost 3 years ago

  • Status changed from Open to Feedback

Why is the crs irrelevant? You still need to specify one whenever you load a layer with an unknown crs into QGIS (or set a default one in options)

#3 Updated by Mike Blechschmidt almost 3 years ago

This command does not load a layer into QGIS. There is only one format conversion DXF -> Shape without transformation.
In 2.xx basically no CRS was asked at this point.

btw:
With a shape as source (without *.prj) also in 3.0 no CRS is queried!

#4 Updated by Nyall Dawson almost 3 years ago

  • Regression? changed from No to Yes

#5 Updated by Nyall Dawson almost 3 years ago

  • Status changed from Feedback to Open

#6 Updated by Nyall Dawson almost 3 years ago

  • Status changed from Open to In Progress

#7 Updated by Nyall Dawson almost 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

#8 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF