Bug report #17936

Crash when deselecting item in Print Layout

Added by Johannes Kroeger almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:25832

Description

1. Open QGIS (you don't need to load anything)

2. Create a new Print Layout

3. Add Map to the blank page (also works for Add Picture, I did not try more elements)

4. Click anywhere

5. QGIS crashes, see attached log and gdb backtrace

64bit Archlinux with:

QGIS version 2.99.0-Master
QGIS code revision f2273c6a11
Compiled against Qt 5.10.0
Running against Qt 5.10.0
Compiled against GDAL/OGR 2.2.3
Running against GDAL/OGR 2.2.3
Compiled against GEOS 3.6.2-CAPI-1.10.2
Running against GEOS 3.6.2-CAPI-1.10.2 4d2925d6
PostgreSQL Client Version 10.1
SpatiaLite Version 4.3.0a
QWT Version 6.1.3
PROJ.4 Version 493
QScintilla2 Version 2.10.2
This copy of QGIS writes debugging output.

std and bt.log Magnifier (11.1 KB) Johannes Kroeger, 2018-01-23 03:07 PM

History

#1 Updated by Nyall Dawson almost 3 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #17916

Also available in: Atom PDF