Feature request #1790

PostGIS query: allow JOINs

Added by Paolo Cavallini about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Data Provider
Pull Request or Patch supplied: Resolution:duplicate
Easy fix?:No Copied to github as #:11850

Description

An useful addition to the query builder would be the ability of adding non only WHERE clauses, but also JOIN with other tables.

History

#1 Updated by Jürgen Fischer about 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

the query builder is just meant to create the where clause to filter on an existing table. That doesn't alter the set of attributes the layer has. Doing that would also require changes elsewhere (in that sense it's a duplicate of #121).

For now joins can be done using views or - if it's just to filter the original table using information from other tables - using subquery expressions

Also available in: Atom PDF