Bug report #17852

Duplicate feature (redigitized) actions enabled for non-editable layers

Added by Nyall Dawson over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:David Signer
Category:Actions
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:25747

Description

The new Duplicate Feature and Duplicate Feature (Redigitized) actions are enabled for non-editable map layers (even read-only layers). This is dangerous because the action bypasses the edit buffer and directly edits an underlying data source.

History

#1 Updated by Denis Rouzaud over 2 years ago

  • Assignee set to David Signer
  • Category set to Actions

#2 Updated by David Signer over 2 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF