Bug report #17801

[Layouts] Unable to move the layout dialog in the background when clicking the main windows

Added by Harrissou Santanna over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:Yes
Operating System:windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25697

Description

Create a layout
When it's open, click in the main window of QGIS. That window gets the focus and you can see that the layout dialog loses it as its menus are grayed.
The bug is that the main window of QGIS does not come foreground
using 63cc1246

layout_foreground.PNG - You can see that the layout at foreground have grayed menus while the main windows has normal coloured menus, with tooltip (means it's the active one) (287 KB) Harrissou Santanna, 2018-01-19 12:43 PM

Associated revisions

Revision 5fcd2dc4
Added by Nyall Dawson over 2 years ago

[layouts] Fix designer windows is always-on-top on Windows 10

Fixes #17801

History

#1 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

I can't reproduce

#2 Updated by Harrissou Santanna over 2 years ago

I still can reproduce with a09cb6f3 (with old 2.x projects or creating an empty one in master)
The only way to not keep the layout dialogs foreground is to close them or minimize them. In the latter case, if you minimize also the QGIS main window, when you "show" it again, the minimized layouts are also shown, still at the foreground.

#3 Updated by Nyall Dawson over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#4 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF