Bug report #17709

Rule edition window too big for small screen (not resizable)

Added by Loïc L'Anton 7 months ago. Updated 5 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:Yes
Operating System:Windows 7 x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No

Description

I'm using QGIS on a 19 inches screen, resolution 1360x766. When I open the rule edition window I'm unable to reach the OK button because that window is taller than my screen. The window is not resizable on the "y axis". The only way I've found to click "OK" is to hide the windows taskbar.

Rule edition window.png (138 KB) Loïc L'Anton, 2017-12-17 10:54 AM

Associated revisions

Revision 5162c468
Added by Alexander Bruy 6 months ago

put rule editor widgest inside a QScrollArea to make dialog resizeable
(fix #17709)

Revision 67ae36c4
Added by Alexander Bruy 6 months ago

Merge pull request #6097 from alexbruy/rule-editor-ui

make rule editor dialog resizeable (fix #17709)

History

#1 Updated by Alexander Bruy 6 months ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#2 Updated by Giovanni Manghi 5 months ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF