Bug report #17706

GRASS Does not work on MacOS with QGIS 2.99 / Master

Added by Tim Sutton almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/GRASS
Affected QGIS version:master Regression?:No
Operating System:MacOS Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:25603

Description

IMHO this is a blocker as it makes processing with GRASS on MacOS unusable.

I get the same type of issue with any algorithm e.g. buffer with a PG layer:

Processing algorithm...
Algorithm 'v.buffer.distance - Creates a buffer around features of given type.' starting...
Input parameters:
{ 'input' : 'dbname=\'swellendam\' port=5432 sslmode=disable key=\'id\' srid=4326 type=LineString table=\'public\'.\'trail_section\' (geom) sql=', 'distance' : 100, 'tolerance' : 0.01, '-s' : False, '-c' : False, 'output' : '/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/c116f14dd71e4080a5eee06b9e0bfdd3/output.shp', 'GRASS_REGION_PARAMETER' : '', 'GRASS_SNAP_TOLERANCE_PARAMETER' : -1, 'GRASS_MIN_AREA_PARAMETER' : 0.0001, 'GRASS_OUTPUT_TYPE_PARAMETER' : 0 }

g.proj -c proj4="+proj=longlat +datum=WGS84 +no_defs" 
v.external input="dbname='swellendam' port=5432 sslmode=disable key='id' srid=4326 type=LineString table="public"."trail_section" (geom) sql=" output="a5a35aa286d0b82" --overwrite -o
g.region n=-33.9916496276855 s=-33.9991302490234 e=20.4648246765137 w=20.4507713317871
v.buffer input=a5a35aa286d0b82 distance=100 tolerance=0.01 output=outputd74c1cae2d104862b5862dba1e23ae96 --overwrite
v.out.ogr -c type=auto input="outputd74c1cae2d104862b5862dba1e23ae96" output="/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/c116f14dd71e4080a5eee06b9e0bfdd3/output.shp" format=ESRI_Shapefile --overwrite
/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/grassdata/temp_location/PERMANENT: /usr/local/opt/grass7/grass-7.2.1/etc/colors/grass: Permission denied 
/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/grassdata/temp_location/PERMANENT: /usr/local/opt/grass7/grass-7.2.1/etc/colors/grass: Permission denied 
Execution completed in 0.13 seconds
Results:
{'output': <QgsProcessingOutputLayerDefinition {'sink':/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/c116f14dd71e4080a5eee06b9e0bfdd3/output.shp, 'createOptions': {'fileEncoding': 'System'}}>}

Loading resulting layers
The following layers were not correctly generated.
/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/c116f14dd71e4080a5eee06b9e0bfdd3/output.shp
You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm.

Buffer with a shp layer:

Processing algorithm...
Algorithm 'v.buffer.distance - Creates a buffer around features of given type.' starting...
Input parameters:
{ 'input' : '/Users/timlinux/gisdata/InaSAFE/Agung/Agung.shp', 'distance' : 100, 'tolerance' : 0.01, '-s' : False, '-c' : False, 'output' : '/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/a44272b4125a4a1c9dec77476a3ab3e9/output.shp', 'GRASS_REGION_PARAMETER' : '', 'GRASS_SNAP_TOLERANCE_PARAMETER' : -1, 'GRASS_MIN_AREA_PARAMETER' : 0.0001, 'GRASS_OUTPUT_TYPE_PARAMETER' : 0 }

g.proj -c proj4="+proj=longlat +datum=WGS84 +no_defs" 
v.external input="/Users/timlinux/gisdata/InaSAFE/Agung/Agung.shp" output="a5a35b657157853" --overwrite -o
g.region n=-8.341999999999928 s=-8.341999999999928 e=115.50800000000004 w=115.50800000000004
v.buffer input=a5a35b657157853 distance=100 tolerance=0.01 output=output632bb5bb5ece40b398a1113638b2eec3 --overwrite
v.out.ogr -c type=auto input="output632bb5bb5ece40b398a1113638b2eec3" output="/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/a44272b4125a4a1c9dec77476a3ab3e9/output.shp" format=ESRI_Shapefile --overwrite
/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/grassdata/temp_location/PERMANENT: /usr/local/opt/grass7/grass-7.2.1/etc/colors/grass: Permission denied 
/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/grassdata/temp_location/PERMANENT: /usr/local/opt/grass7/grass-7.2.1/etc/colors/grass: Permission denied 
Execution completed in 0.08 seconds
Results:
{'output': <QgsProcessingOutputLayerDefinition {'sink':/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/a44272b4125a4a1c9dec77476a3ab3e9/output.shp, 'createOptions': {'fileEncoding': 'System'}}>}

Loading resulting layers
The following layers were not correctly generated.
/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/a44272b4125a4a1c9dec77476a3ab3e9/output.shp
You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm.

Douglas smoothing fails with a different error:

Wrong or missing parameter value: Percentage of the points in the output of 'douglas_reduction' algorithm

(I had used 50% for the parameter in the above)

Trying to use v.report on a shp layer:

Processing algorithm...
Algorithm 'v.report - Reports geometry statistics for vectors.' starting...
Input parameters:
{ 'map' : '/Users/timlinux/gisdata/InaSAFE/Agung/Agung_multi_buffer.shp', 'option' : 0, 'units' : 0, 'sort' : 0, 'html' : '/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/92b03c85c0a14f73abb44231d033f286/html.html', 'GRASS_REGION_PARAMETER' : '', 'GRASS_SNAP_TOLERANCE_PARAMETER' : -1, 'GRASS_MIN_AREA_PARAMETER' : 0.0001 }

g.proj -c proj4="+proj=longlat +datum=WGS84 +no_defs" 
v.external input="/Users/timlinux/gisdata/InaSAFE/Agung/Agung_multi_buffer.shp" output="a5a35b7695a3c55" --overwrite -o
g.region n=-8.233491914486384 s=-8.450507472844231 e=115.61695199802749 w=115.39905354640074
v.report map=a5a35b7695a3c55 option="area" units="miles" sort="asc" > "/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/92b03c85c0a14f73abb44231d033f286/html.html" --overwrite
/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/grassdata/temp_location/PERMANENT: /usr/local/opt/grass7/grass-7.2.1/etc/colors/grass: Permission denied 
Traceback (most recent call last): File "/Users/timlinux/dev/cpp/QGIS-QtCreator-Build/output/python/plugins/processing/algs/grass7/Grass7Algorithm.py", line 398, in processAlgorithm self.convertToHtml(parameters[outName]) File "/Users/timlinux/dev/cpp/QGIS-QtCreator-Build/output/python/plugins/processing/algs/grass7/Grass7Algorithm.py", line 825, in convertToHtml with open(fileName, 'r', encoding='utf-8') as f: FileNotFoundError: [Errno 2] No such file or directory: '/var/folders/g6/fnh1vyx13q728xq52nw7yx400000gn/T/processing_cbc81a395f3243e4af26c2b501e5c259/92b03c85c0a14f73abb44231d033f286/html.html' 

Execution failed after 0.08 seconds

Loading resulting layers
Algorithm 'v.report - Reports geometry statistics for vectors.' finished
HTML output has been generated by this algorithm.
Open the results dialog to check it.

And so on....

I think there is a systematic error causing the run failures and then other ad hoc errors (such as s the simply error I pointed to above).....it really needs someone to systematically test each alg on Mac to see if it works...

History

#1 Updated by Nyall Dawson over 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #17555

Also available in: Atom PDF