Bug report #17702

Paste Features as... doesn't copy original layer fields

Added by Harrissou Santanna over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25599

Description

Select features, copy them
Edit menu, Paste features as, select Scratch temporary Layer
Apply and Open the newly created layer attribute table
In master, the attribute table is empty (I will need to check if it's the case also on Linux but it occurs for sure on Windows). In 2.18.15, you have the fields available and filled.

This occurs also when you choose a "New vector layer" as destination; you'll notice in the "Save Vector Layer as..." dialog that the fields section is empty!

PS: I'm not sure of the selected category

Associated revisions

Revision 7febd1e4
Added by Nyall Dawson over 2 years ago

Fix pasting features to new layer doesn't paste fields

Fixes #17702

History

#1 Updated by Olivier Dalang over 2 years ago

Confirmed here on Windows (qgis rev e02ff050ad). I think this should be flagged as blocker since it's a regression.

#2 Updated by Nyall Dawson over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#3 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF