Bug report #17619

QGIS 3D: add per layer option for vertex ordering of 3D polygon layers

Added by Andreas Neumann over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:3D
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25516

Description

Depending on the data source, the vertex ordering is clock-wise or counter-clock-wise.

A "per layer" vertex ordering option should be added to support both cases.

Associated revisions

Revision b773d617
Added by Martin Dobias over 2 years ago

[3d] Tessellator fixes + culling mode configuration for 3D polygons

- missing vertical walls since a recent tessellator crash fix (fixes #17604)
- choice of the culling mode - no culling / back face / front face (fixes #17619)
- more unit tests for tessellator

History

#1 Updated by Martin Dobias over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#2 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF