Bug report #17604

3D buildings are no longer working in 3D canvas

Added by Saber Razmjooei over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:3D
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25501

Description

The buildings do not render correctly in the latest version of master (19b062c)

Attached is the file that used to work.

Associated revisions

Revision b773d617
Added by Martin Dobias over 2 years ago

[3d] Tessellator fixes + culling mode configuration for 3D polygons

- missing vertical walls since a recent tessellator crash fix (fixes #17604)
- choice of the culling mode - no culling / back face / front face (fixes #17619)
- more unit tests for tessellator

History

#2 Updated by Martin Dobias over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#3 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF