Bug report #17594

Temporary scratch layer dialogue should also list curve geometry types as supported types

Added by Andreas Neumann almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25491

Description

When creating a new temporary scratch layer (through menu "Layer" --> "Create Layer" --> "New Temporary Scratch Layer") only simple feature geometry types are offered.

The following geometry types should be offered in addition:

  • CompoundCurve
  • CurvePolygon
  • MultiCurve
  • MultiSurface

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Category changed from Vectors to Digitising

#2 Updated by Nyall Dawson almost 3 years ago

Those types aren't specifically offered by the dialog, but the provider still allows curves. E.g. make a LineString memory layer, and you can insert curves in the layer.

#3 Updated by Nyall Dawson almost 3 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

#4 Updated by Andreas Neumann almost 3 years ago

  • Status changed from Closed to Reopened
  • Resolution deleted (invalid)

Ok - just tested and you are right - circular arcs are supported in LineString or Polygon layers.

But the issue is still valid. The dialogue needs to be adjusted to make it clear that curves are supported, e.g. by saying

  • Linestring / Compoundcurve
  • Polygon / CurvePolygon
  • MultiLine / MultiCurve
  • MultiPolygon / MultiSurface

This would a very simple fix just in the dialogue and wouldn't require any other changes.

It would also be good to use the "official" OGC terms and not reinvent our own terms. E.g. "Line" should be "LineString"

#5 Updated by Andreas Neumann almost 3 years ago

  • Subject changed from Temporary scratch layer doesn't allow to create curve geometry types to Temporary scratch layer dialogue should also list curve geometry types as supported types

#6 Updated by Andreas Neumann over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Reopened to Closed

Is now implemented - thanks to Harissou!

Also available in: Atom PDF